La tubería de activos no sirve a los activos, pero no hay errores. ¿Se ve bien esta configuración?

El problema que quiero resolver

soy nuevo en RoR (pero un desarrollador experimentado) y siempre me ha gustado... ¡Pero mi tubería de activos está en problemas! Tengo una aplicación heredada que estoy modificando para usar tuberías de activos. Leí un artículo tras otro en so y otros sitios web, pero no pude hacer que funcionara. Los detalles son los siguientes:
Versión Ruby: 2.0.0 - p353
Versión Rails: 3.1.12
Contenido del directorio APP/assets/javascript:
application.js          
bootstrap.js            
event_calendar.js       
jquery-ui-timepicker-addon.js   
jquery-ui.js            
jquery.js
jquery.prettyPhoto.js
jrails.js
mce_editor.js
rails.js
/tiny_mce
Contenido de la aplicación de archivos. JS:
//= require bootstrap
//= require event_calendar
//= require jquery
//= require jquery.prettyPhoto
//= require jquery-ui
//= require jquery-ui-timepicker-addon
//= require jrails
//= require mce_editor
//= require rails
//= require_tree ./tiny_mce
Contenido del directorio APP/assets/stylesheets:
application.css         
/blueprint          
bootstrap-responsive.css    
bootstrap.css           
common.css          
contributed.css         
event_calendar.css      
jquery-custom.css
jquery-ui-timepicker-addon.css
marketing.css
prettyPhoto.css
registration.css
sysadministration.css
template.css
/ui-darkness
Contenido de la aplicación de archivos. CSS:
/*
*= require bootstrap
*= require bootstrap-responsive
*= require common
*= require contributed
*= require event_calendar
*= require jquery-custom
*= require jquery-ui-timepicker-addon
*= require marketing
*= require prettyPhoto
*= require registration
*= require sysadministration
*= require template
*= require_tree ./blueprint
*= require_tree ./ui-darkness
*/
Configuración en configuración/aplicación. RB:
config.assets.enabled = true
Asistente en la aplicación/vista/diseño/aplicación. Html. Oficina de readiestramiento de empleados
<%= stylesheet_link_tag    "application" %>
<%= javascript_include_tag "application" %>
Configuración/entorno/configuración en desarrollo. RB:
config.assets.compress = false
config.assets.compile = true
config.assets.debug = true  
Contenido de la carpeta/público/activo:
(empty)
Cuando Navegué a localhost:3000/assets/application.js, sólo conseguí el contenido de la aplicación. Devuelve el archivo JS. Lo mismo se aplica. CSS. Sin embargo, hay un punto y coma obvio en la aplicación. JS:
//= require bootstrap
//= require event_calendar
//= require jquery
//= require jquery.prettyPhoto
//= require jquery-ui
//= require jquery-ui-timepicker-addon
//= require jrails
//= require mce_editor
//= require rails
//= require_tree ./tiny_mce
;
Intenté rastrear el punto y coma, pero tuve mala suerte. Cambié el orden de las declaraciones requeridas, pensando que podría ser capaz de reducirlas. Código JS, pero este esfuerzo no tuvo éxito.
Cuando renderizo mi página, no tiene ningún estilo o JS (como se esperaba, porque la tubería de activos no funciona).
También intenté usar la instrucción require_tree . en mi aplicación. CSS y aplicaciones. JS, en lugar de enumerar explícitamente cada archivo, tampoco funciona.
Por último, no se muestran errores en la consola de mi servidor. Rails parece pensar que estos activos están siendo atendidos correctamente:
Started GET "/assets/application.css?body=1" for 127.0.0.1 at 2014-08-02 15:31:02 -0400
Served asset /application.css - 304 Not Modified (0ms)

Started GET "/assets/application.js?body=1" for 127.0.0.1 at 2014-08-02 15:31:02 -0400
Served asset /application.js - 304 Not Modified (0ms) 
¿Hay alguna omisión obvia en mi configuración basada en la información que he proporcionado? ¿Alguien tiene alguna sugerencia para que esto funcione?
Gracias!

Solución de referencia

decidí actualizar a Rails 3.2.18 para resolver este problema (seguí la Guía Rails # 318 "actualizar a Rails 3.2"). Ahora, mi js y CSS se envían al navegador:
application.js
application.css
La consola del servidor muestra los activos entregados por separado (modo de desarrollo):
Started GET "/assets/bootstrap.css?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /bootstrap.css - 304 Not Modified (0ms)

Started GET "/assets/jquery-custom.css?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /jquery-custom.css - 304 Not Modified (0ms)

Started GET "/assets/contributed.css?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /contributed.css - 304 Not Modified (0ms)

[deleted for brevity]

Started GET "/assets/application.css?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /application.css - 304 Not Modified (0ms)

Started GET "/assets/jquery.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /jquery.js - 304 Not Modified (0ms)

Started GET "/assets/jquery.prettyPhoto.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /jquery.prettyPhoto.js - 304 Not Modified (0ms)

Started GET "/assets/jquery-ui.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /jquery-ui.js - 304 Not Modified (0ms)

Started GET "/assets/jquery-ui-timepicker-addon.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /jquery-ui-timepicker-addon.js - 304 Not Modified (0ms)

Started GET "/assets/bootstrap.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /bootstrap.js - 304 Not Modified (0ms)

Started GET "/assets/event_calendar.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /event_calendar.js - 304 Not Modified (0ms)

Started GET "/assets/mce_editor.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /mce_editor.js - 304 Not Modified (0ms)

Started GET "/assets/jrails.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /jrails.js - 304 Not Modified (0ms)

Started GET "/assets/rails.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /rails.js - 304 Not Modified (0ms)

Started GET "/assets/application.js?body=1" for 127.0.0.1 at 2014-08-04 06:07:20 -0400
Served asset /application.js - 304 Not Modified (0ms)